• 0
Sign in to follow this  
Gene Inari

Games crash on start. Halp?

Question

Gene Inari

crashhalp.png

I get this on Simcity and Team Fortress 2 when I start them up. It started suddenly yesterday, and in the mean time I've done just about everything I can think of, updating my OS, updating my drivers, running CCeaner, reinstalling. None of it has worked.

Anyone here have any ideas? SC2013 and TF2 are two of my main games, so this is a major issue for me. :|

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
DZComposer

First: If you are overclocking, set everything back to stock. If that fixes it, you know where your problem is.

Next culprit is drivers. I know you did an update, but the error is specifically referencing a DLL file from the AMD Catalyst driver, so that's your prime suspect. Try an older driver.

Also run a memtest. Bad ram can look like a driver failure. http://www.memtest.org/

I was about to nuke my win 8 box because of a kernel driver problem once. I ended up doing a memtest for the hell of it, and lo and behold I had a stick that was so bad it crashed memtest!

It could also be a video card failure, but I think that is highly unlikely.

Share this post


Link to post
Share on other sites
  • 0
Gene Inari

EDIT: It's broken again... >.<

I redid drivers and all it did was change which DLL is throwing the error.

Other games such as Minecraft, Warframes, and such still work, which is the odd part.. :|

Editedit: Working again...

Share this post


Link to post
Share on other sites
  • 0
LoneWolf

I have a permanent fix for Simcity 2013

 

don't play simcity 2013

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Gene Inari

I have a permanent fix for Simcity 2013

 

don't play simcity 2013

Why is EVERYONE ragging on Simcity? Oh my goodness...

Share this post


Link to post
Share on other sites
  • 0
Arashikage

Because It's a semi decent game but just about as broken as many of EA's recent games.  

Share this post


Link to post
Share on other sites
  • 0
Dr. Orange

Go into advanced options. You might need to edit how the game starts up. I had this problem too.

 

Set it is safe mode 

 

"-safe"

 

Try this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this