Terramax

Strange Star Fox Adventure Region Problem

Recommended Posts

Terramax

OK guys, this is a weird one.

So I live in Japan and have a Japanese gamecube, so in order to play English games, I had to order an action replay and an American copy of SF Adventure.

I finally have all the tools to sit down and play when suddenly.... THE AMERICAN COPY IS PLAYING IN FULL JAPANESE! It seems that, despite being a US game, the Japanese language code was left in the game, and if you play it on a Japanese gamecube, it automatically switch to Japanese.

I've looked on the options menu and I can't seem to find any language options. Does anyone know if there is somewhere in the options to change the language?

  • Like 1

Share this post


Link to post
Share on other sites
Dr. Orange

Doesn't the US edition have the option for Japanese? Maybe your Japanese GameCube is detecting it and locking you in regardless of the Action Replay.

  • Like 1

Share this post


Link to post
Share on other sites
Terramax

Yes, that's exactly what it's doing. Therefore, I'm asking if anyone knows of a workaround?

Share this post


Link to post
Share on other sites
Dr. Orange

I think you just need to get a GC from the states m8. Sorry bout that.

  • Like 1

Share this post


Link to post
Share on other sites
LinkyHYC

You should already know by now who says what and what to do, the game is 15 years old for Christ's sake :p

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now